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1. Objective

This technical guide provides step-by-step instructions for consuming Archicad BIM models in Revit
using Industry Foundation Classes (IFC) 2x3 exchange format so that the Revit user can continue to
build on the models without remodelling. This is particularly useful for contractor who use Revit to

build on architect’s BIM models created using Archicad.

Please insert provisions for BIM interoperability below into an appropriate section of the Consultancy
Agreement between the Employer and the Consultant. The following technical guide aims to assist
the Employer in specifying what the Consultant is required to deliver in ensuring BIM interoperability
between different modelling software. These clauses should be read in conjunction with the

Employer’s Information Requirements (EIR) and Client’s IDD Requirements (CIR) where applicable.

2. Prerequisites & References

This Guide is based on the following BIM authoring tools:

- Archicad (version 22 or later recommended)

- Revit (version 2020 or later recommended)
This Guide also makes references to the following documents:

a) Graphisoft Corenet X and IFC-SG guides

(https://graphisoft.com/sg/solutions/corenet-x-and-ifc-sg)

b) IFC-SG Revit Content “How To” Guide

(https://interoperability.autodesk.com/singapore/downloads/IFC-

SG_RevitContentHowToGuide v1.0.pdf)

Please refer to the following workflow diagram for an initial guide.
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checks before exporting to IFC

Check for proper export &
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3. Preparing the Archicad Model

Proper preparation of the Archicad model is essential to minimise data loss during the IFC export

and subsequent IFC import into Revit. The following steps prepare Archicad model for IFC export.

3.1 Classifying Elements

Every ArchiCAD element to be exported, must be classified.

KCIassification is key! Here are two reasons why. \

1) Appropriate properties will only appear in the element settings if the classification is

correct.

2) IFC export Type mapping will be based on these classifications. (e.g. ‘Space’ will be

\ exported as 'ifcSpace’) J

a) Select the element and open ‘Element Selection Settings’, then click on ‘Classifications and

Properties’ as shown.
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b) Choose the appropriate classification from the drop-down list.
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Q ISearch Classifications

> @ Site
> @ Space
v @ Elements

> ) Wall

k > @ Footing

L > L@ Column

> @ Pile

> @ Beam

5 B Slab

> @ Roof

N & Shell

> @ Covering

3 > B Stair

> L@ Ramp

> ) Railing

> @ Curtain Wall
> @ Member

> @ Plate

> @ Shading device
B & Chimney

v @ Construction Element
> @ Building Element Proxy
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Each ArchiCAD element classification will have a corresponding entity within the IFC schema.

IFC Entities Schema

v @B (itcObjectDefinition)
v @B (fcContext)
B 1rcProject
~ @B (icObject)
v g; HcGroup
v H2 HeSystem

H, IeBuildingSystem
Y KeDistributionSystem
[y ifcZone

v @B (fcProduct)
v @8 (HcElement)

v @B (fcBuildingElement)
53 IfcBeam
(P WeBuildingElementProxy
H HeChimney
D IfeColumn
E IfcCovering
Effl feCurtainwall
[] tfeDoor
“ WcFooting
1 teMember

Archicad Classification V2.0 Schema

v @ ARCHICAD Classification - v 2.0

v 2
%) Geographic Element
%) Massing
W@ Civil Element

v B Space

arch Classifications

Site

Q External Space
®) Internal Space
v B Elements
%) Construction Element
v 5 Opening
v % Door
B Gate
& Trapdoor
‘ B Window
B Recess
‘ % Empty Opening
® Provision for Void
) Element Component
% Fumnishing

‘ %) MEP Element

If new classification items are added to Archicad, there is a need to do a type mapping to an IFC entity.

Please refer to (https://help.graphisoft.com/AC/24/int/ AC24 Help/115 IFC/115 |FC-38.htm) for

the steps involved.
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Predefined IFC properties for objects are available by default in Archicad. To populate these

properties, please refer to the following steps.

a) Select the element and open the ‘Element Selection Settings’.

b) Within the settings, go to ‘Classification and Properties’. Click on the ‘Manage IFC

Properties’ button as shown.

el
~ D GEOMETRY AND POSITIONING

Top Link:

w
=)
=]
=

-I 8600
Home Story:

2. 2nd Floor ~

to Project Zero  #

-
PROFILE OFFSET MODIFIERS
~ [l FLOOR PLAN AND SECTION

Show Projection
" ‘CUT SURFACES
™5 override Cut Fill Pens
w7 OUTLINES
g/ Uncut Lines
9_[,,] Uncut Line Pen
1 VAN Bl Finmne

» (5 MODEL

? X

Selected: 1 Editable: 1

7] sH-s-=shape-02 end »
b s
—
Reference Line:
..... 4
=9 #Hr o
To Absolute Display Li... [
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Solid Line _—
0.13 mm &7 [
(=] err |
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CLASSIFICATIONS
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Material [Pset_CoveringCo...

ARCHICAD Classification - v...

Covering

(4TP3vRIaliQQqXv3
WXAT P3vRIaJiQ0qXv3

EC-06
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c) From the list of properties, add in the required values. After editing, click ‘Ok’.

/" Manage IFC Properties r :

Selected: 1 Editable: 1 W V)
Mame Value Type

» Pset_ConcreteElementQuant
= Pset_CoveringCeiling

(| FragilityRating IfcLabel
O Permeability IfchormalisedRatioMeas
O TileLength IfcPositivelengthMeasu
|:| TileWidth IfcPositivelengthMeasu
" Pset_CowveringCommon
O AcousticRating IfcLabel
[ combustible lfcBoolean
[ Finish IfcText
FireRating I o
(| FlammabilityRating IfcLabel
O FragilityRating IfcLabel
Material 23 SH - 5-shape-02 end lfcLabel
|:| Reference Ifcldentifier
O SurfaceSpreadOfFlame IfcLabel
TotalThickness 25 5285 IfcPositiveLengthMeasu

» Pset_CoveringFlooring

» Pset_Draughting

] Pset_ElementShading

] Pset_FireRatingProperties

] Pset_ManufacturerOccurremn

Mew... Apply Predefined Rule...

Cancel oK
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a) To define the IFC Translator setting, go to ‘File’ -> ‘Interoperability’ -> ‘IFC Translators’.

File Edit View Design Document

D New »
(=5 Open v
[ Close Project  Ctrl+Shift+W

5 save Ctrl+S
|5 Save as... Ctrl+Shift+S

@ Export to BIMcloud...

53] Publish BIMx Hyper-model...

Options  Teamwork Window Help

Interoperability b 0 Merge...

@ Archicad Home  Ctrl+Shift+H Guides = il Grids = Trace - E Measure Groups « @ 3D Cutaway

Interior - Furniture » | Reception Balcony »

(1) 0 Welcome [0 Welcome]

ersion, not for resale. Courtesy of Graphisoft

] @ IFC Project Manager... Ctrl +Alt+]

E Plot Setup...

|
External Content P|0 IFC
Libraries and Objects D SAF
Info ¥ DXF-DWG ;

Classifications and Properties

’b IFC Translators...

= IFC Local Preferences...

g QD Merge to IFC Model...

HIT L1

Plot... DS g & Detect IFC Model Changes...
Page Setup... Ctrl+Shift+P  |¢< Import Paint Clouds... &) Update with IFC Model...
5 Print... Ctrl+P E‘?« Place Mesh from Surveyors Data... —— & éﬂ Ll $
| +
Exit SHkS | pizersl T O
i3 yany I T fim i) Ll

b) Under ‘Translators for Export’ click ‘General Parametric Export’. Within ‘Settings’, change ‘IFC

Schema’ to ‘IFC2x3’ and set ‘Model View Definition’ to ‘Coordination View Version 2.0’. This

is the most compatible version with Revit. You can follow the settings as per the image below.

i

Al IFC Schema

Q. Search IEC Translatc

Name
= Translators for Import
AECOsim Building Designer Import
Allplan Engineering Import
DDS-CAD MEP Import
Exact Geometry Import
General Import
Modeling Applications Impert
Plancal nova Import
Revit MEP Import
Revit Structure Impart
Scia Engineer Import
Structural Analysis Model Import
Tekla Structures Import
~ Translators for Export
AECOsim Building Designer Export
Alliplan Engineering Export
BIM4You (4D/50) Export
CostX Export
DDS-CAD MEP Expart
Exact Geometry Export
/7 General Export

IFC4 Design Transfer View-based Export

IFC4 Reference View-based Export

Name of Translator for Export:

General Parametric Export

Desaription:

+ Export for general purposes. Exports as many parametric elements as possiole with all
ARCHICAD Element Properties and Classifications,

IFC Schema:

Model Filter:

~ SETTINGS

ersion Presets:

IFC2x3

Medel View Definition: Coordination View Version 2.0 -

Name of Customn MVD:

All 3D elements

Type Mapping:

ARCHICAD Classification - v 2,0 IFC2x3

Geometry Conversion:

Parametric extruded geometry (where possible) (2)

Property Mapping:

Standard IFC2x3 Properties

Data Conversion:

Plancal nova Export

Revit Export for Reference Model
Revit MEP Export

Revit Structure Export

Scia Engineer Export

Tekia Structures Export

New.. Delete Set Preview

Element Properties and Classifications anly

Unit Conversion:

Metric (mm) (deg) (USD)

Cancel oK |
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¢) Onthe same dialog, click additional settings under ‘Model Filter’. Check ‘Grid Systems and
Elements’

Available Presets:

All 3D elements

All 3D elements (Coordination View (Surface Geometry)) (Coordination View (Surface G... I
All 3D elements with annotations

AN AN slamante with Rnae £ find o 30U

Hew.., Rename...

Delete... —D

* SETTINGS
Select 3D Elements to Export

by Structural Function:

‘A\Ielements v|

by IFC Domain:

LAl

IfcElement
IfcProxy
IfcSpatialElement

Select 2D Elements to Export
Grid System and Elements l

[:] Lines, Texts, Labels, Fills

[:] Door / Window 2D Views

~ COMPATIBILITY

Compatibility of current Preset with Model View Definitions:

~ IFC2x3 Schema

+/ Coaordination View Version 2,0 I
A Coordination View [Surface Geometry)

o/ rranrant Nacian BRI 3000

ov

erride Settings to Ensure Compatibility
* RELATED TRANSLATORS

This Preset is currently used in the following Translators for Export:

AECOsim Building Designer Export (IFC2x3, Coordination View Version 2.0}
BiM4You [4D/5D) Export (IFC2%3, Coordination View Version 2.0}

Cost¥ Export (IFC2x3, Coordination View Version 2.0}

DDS-CAD MEP Export (IFC2x3, Coordination View Version 2.0}
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d) Click on the additional settings under ‘Type Mapping for IFC Export’. Click on the ‘Map IFC

Types for Export’ button and follow the settings shown in the image below.

T T TP =
/" Type Mapp ? X /* Map ? X
Available Presets: Map Elements by: '::) Element Type (D Source Classification System:
ARCHICAD Classification - v 2,0 IFC O Classification [0) | ARCHICAD Classification - v 2.0 V ‘
ARCHICAD Classification -v 2.0 IFC4 | .
i | Show IFC Entities for IFC2x3 Schema v ‘
|
Mew. Rename... Delete... B > IFC Type
~ SETTINGS ‘ 7 Search Classifications Mapping Status: by Parent
= o @) Unclassified Elements Custom
Map IFC Types for Export... ] ~ @) ARCHICAD Classification -v 2.0
i IFCT,
T > B site ype
> 5P space
Compatibility of current Preset with IFC Schemas O
> B Elements )
 IFC2x3 Schema Predefined Type:
A > %) Components
IFC4 schema .
5 B Msterials User Defined Type:
IFC Type Product
+ RELATED TRANSLATORS
Predefined Type:
This Preset is currently used in the following Translators for Export:
N N . N User Defined Type:
AECOSsim Building Designer Export (IFC2:3, Coordination View Version 2.0)
Allplan Engineering Export (IFC2x3, Coordination View Version 2.0) . . .
BIM4You (4D/5D) Export (IFC2x3, Coordination View Version 2,0} Reset Mapping Synchronize Predefined Type values when possible
CostX Export (IFC2x3, Coordination View Version 2.0)
Cancel oK

e) Click on the additional settings under

‘Conversion of ARCHICAD elements’,

‘Geometry Conversion for IFC Export’. Under

ensure the following settings are followed.

/" Geome

r IFC

version

1 Available Presets:
Optimized for Tekla Structures (2)

Parametric extruded geometry (where possible]

Parametric extruded geometry (where possible)

Drarica RDFD manmatn:
MNew... Rename...

~ SETTINGS

e}

X

12

Delete...

ﬁonwrsion of Archicad elements

Export geometry of IFC Type Products
Export gross geometry of elements
Export all model elements’ geometry as:
Elements in Solid Element Operations
Elements with junctions

Define IFC model position by:

Hierarchical Archicad elements

Curtain Wall
\ Stair

Export only geometries which "Participate in Collision... O

O
Parametric with exceptions
Extruded/revolved
Extruded/revolved without jun...

Survey Point and Project Qrigin

Keep hierarchy
KeeE hierarchy

Railing
' IFC Schema related export options

\ Material preservation maode [IFC2x3 only)

Convert to single element

Explode only when necessary t...

w—
h Composite structures and Complex Profiles

Split complex Building Elements into parts
IfcBuildingElement

O
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Click on the additional settings under ‘Data Conversion for IFC Export’. Under ‘Select

ARCHICAD Data to Export’ and ‘Select Derived Data to Export’, please check the following

checkboxes.

N

Data Conversion for IFC Export 4
Available Presets:

All derived data

All Element and Component data

Element Properties and Classifications only

IEF Dramartiac auailahla in IEC Draiart kanaasr

Mew... Rename... Delete...

&

s

Select Archicad Data to Export:

Classifications

Element Properties

[ Building Material Properties and Classifications

All

[ Element parameters

[] Component parameters
Door-Window parameters
[ Zone Categories

=

ol

Export IFC Properties:
Q) Al IFC Properties

r:i‘; Only Properties set in Property Mapping for the selected Translator

Select Derived Data to Export:

IFC Base Quantities
[] IFC Space Containment Filter Containment..,

C] IFC Space Boundaries

~ COMPATIBILITY

Compatibility of current Preset with Model View Definitions:
¥ IFC2x3 Schema
+/ Coordination View Version .0

+/ Coordination View (Surface Geometry)

W rrnran + Nacinn AIKA 3010
Override Settings to Ensure Compatibility
~ RELATED TRANSLATORS
This Preset is currently used in the following Translators for Export:

General Export (IFC2x3, Coordination View Version 2.0)
General Parametric Export (IFC2x3, Coordination View Version 2.0}

Cancel
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3.4 Quality Check within Archicad
The 1% level quality check should be done within Archicad before exporting to IFC. The check should

ensure that all the elements have been properly classified via the IFC Project Manager.

a) Navigate to ‘IFC Project Manager’ by clicking on ‘File’ -> ‘Interoperability’ -> ‘IFC’ -> ‘IFC

Project Manager’.

[File Edit View Design Document Options Teamwork Window Help

rchicad Home rl+Shift+ uvides » I Grids = w [12 Measure roups w % utawa
(ot Archicad H Ctrl+Shift+H | Guid £ Grid M & Group 3D Cutaway
D Mew 3 Geometry Method: Reference Line Location:

E -
=~ Open ¥ [shell - Roaf ’ Profile Origin -

[} CloseProject  Ctrl+Shift+W
[2"11 0 Welcome [0 Welcome]

Eﬂ Save Ctrl+5
ﬁ Save as... Ctrl+Shift+5
EJ\_ Export to BIMcloud...

53] Publish BIM:x Hyper-model..
Interoperability b BB Merge... » |
External Content 2 ‘@ IFC 2 ‘ﬂ[\& IFC Project Manager...  Ctrl+Alt+|
Libraries and Objects 2 ‘$ SAF » /%:u: IEC Translators...
Info D DXF-DWG E % IFC Local Preferences...
E Plot Setup... Classifications and Properties 2 %3 Merge to IFC Model...
E Flot. ID5 b |§E Detect IFC Model Changes...
Page Setup... Ctrl+Shift+P | = Import Point Clouds... @) Update with IFC Model...
5 Print... Ctrl+P LEI@ Place Mesh from Surveyors Data...
Exit Ctrl+Q Send Model to Google Earth
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b) The hierarchy of the IFC schema can be found within the IFC Project Manager. Here, you can

examine each object for its classifications and properties. At this stage, perform a quality

check on your existing elements before proceeding.

fm spatial Relation

v 5 VRF - Liquid Medium 84
D Relation
fm spatial Relation

+ %5 VRF - Liquid Medium 9
D Relation
fm spatial Relation

v F7 vT0I01- 1

D Relation

FC Project =
= L] — —
@ T % [ Anseleced: Editable: 1 vs ||V |
w5 3. 3rd Floor MName Value Type
» TEi IfcBeam (58)
» T IfcBuildingElementProxy (98) I
v Ei IfcColumn (22) S (s
] sc-301
| [==E] -
0 sc02 Name SC-302 [feLabel
Description IfcText
f] sc-303 P
] sc-304
Tag 2- 9B3DDESE-4122-264E-8FEC-C  Ifcldentifier
f] sc-30s
] sc-306 .
i AC_Pset_RenovationAndPha
 sc-307
U SC-308 = Pset_ColumnCommon
[ sc3o9 FireRating @1 1 hour Ifelabel
kL E Q vy
Reference Z) HEB 260 Ifcldentifier
EI Relation Slope 2o 90.00° IfcPlaneAngleMeasure

Pset_ConcreteElementGener:

[ ConcreteCaveratLinks IfcPasitiveLlengthMeasure

[ concreteCoverAtMainBars IfcPositiveLengthMeasure

[ constructionToleranceClass Ifclabel
O ConstructionType IfcLabel
O DimensionalAccuracyClass IfcLabel
[ EnvironmentalClass Ifclabel
I [ FireRating IfeLabel
O LifeCycleEnvironmentalload IfcText
Mew... Apply Predefined Rule...

c) If you wish to use graphical overrides to perform a quick filter of objects not classified,

please refer to https://graphisoft.com/sg/solutions/corenet-x-and-ifc-sg for the guides and

materials required.
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4. Exporting IFC

4.1 IFC Export Settings from Archicad

1. Go to File — Save as — IFC File

2. Configure export settings:
- Visible elements (on all stories) for the Export

- General Parametric Export for the Translator

buildingSMART Singapore
BIM Interoperability Guide
Version 1 (31 January 2025)

/Y Save 3D
Savein | [ Documents @ T > @~
/\ MName : Status Date modified
o4 Custom Office Templates 15/9/2020 9:49 pm
Home CyberLink 15/9/2020 9:49 pm
Downloads 15/9/2020 9:49 pm
- Fax 16/3/2021 5:36 pm
Desktop Graphisoft 26/11/2024 4:28 pm
My Digital Editions 15/9/2020 9:49 pm
— OneMote Motebooks 15/9/2020 9:49 pm
Libraries Python Scripts 15/9/2020 9:49 pm
Scanned Documents 1/5/2021 3:16 pm
- Comramma Caldar AFT AW 1 s
This PC
h Export: Visible elements (on all stories) v Filter...
Translator: General Parametric Export W Options...
Metwork
File name: S-Office.ifc w Save
Save as type: IFC Files (*.rfc) w Cancel
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5. Model Quality Check

Prior to importing the files to Revit, please use IFC viewers like Open IFC viewer or BIMvision to open

the IFC file and check if the IFC classifications are properly defined.
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6. IFC Import to Revit

When importing IFC files into Revit, Revit converts each element from the IFC file into a native Revit
object, which can be time-consuming. The steps provided in this guide help ensure the resulting

model maintains good quality standards.

6.1 Import Configuration

1. Open Revit

2. Go to ‘File’ -> ‘Open’ -> ‘IFC’

Create  Insert  Annotate  View Manage Add-Ins Mo

B | opans 2 Revit-compatinla e,

& ew 5 L_I Cloud Model
& Opens a Revit doud modl,
=, @ Project
7 oo | T coeres heve o
D Family
E Save Opens a Revit family.
Revit filo

H, Save As b [TEl  Opens any Revit file type.
- .
IFC
Opens an IFC file.
Export
-+ 5P

@ IFC Options
Sets options for the IFC template and
-3

q ; . N dass mapping.

[y Samele Pl

D /" Opens a Revit sample fle
Close
a8

Options | | Exit Revit

3. Configure import settings:

- Disable ‘Auto-Join Elements’ as it leads to undesirable results for complex structures and long

export times.

- Ensure ‘Correct lines that are slightly off axis’ is checked.

u Open IFC File
Look in: [l This PC v 4m B X Views v
Name . Status Date modified Type <
Devices and drives (1)
=50s (€) Local Disk
File name: v
Files of type: IFC Files (*.ifc) e
Tools ¥ [ Autoloin Elements 18 Correct lines that are slightly off axis Qpen Cancel
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6.2 |IFC Mapping to Revit

IFC class mapping in Revit controls how IFC elements are translated into native Revit families and
categories. It maps IFC entities like ifcWall to Revit categories like Walls, based on a mapping schema

file. It also determines which elements become Revit families or generic models.

Some IFC classes don't have direct Revit equivalent classes, and complex ones may default to
Generic Models. Custom IFC entities might need manual mapping, and this can be done be
customising the import mapping file via the ‘Import IFC Options’. For example, the IFC type can be
defined in Archicad for Slabs so that Revit user can assign to the proper Revit Category and Revit

Sub-Category.

IFC Class Name IFC Type Revit Category Revit Sub-Category A
IfcReinforcingMeshType Structural Fabric Areas
IfcRoad Roads
IfcRoof Roofs
ifcRoof Type Roofs
IfcSanitary Terminal Plumbing Fixtures
IfcSanitaryTerminalType Plumbing Fixtures
IfcSensor Specialty Equipment
IfcSensorType Specialty Equipment
IfcSite ‘Site
IfcSlab "Floors
ifcSlab BASESLAB Structural Foundations
ifcSlab FLOOR Floors
ifcSlab LANDING Stairs Landings
ifcSlab ROOF Roofs
ifcSlabType Generic Models
IfcSlabType BASESLAB Structural Foundations
ifcSlabType FLOOR Floors
ifcSlabType LANDING Stairs ‘Landings
IfcSlabType ROOF Roofs
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This section goes through how to set up the project location in both Archicad and Revit, as well as

how to use IFC file format to exchange the two file formats while retaining the geo-referencing

values.

7.1 Adding geo-referencing values to Archicad

Add reference points to the model via the following steps:

1) Go to Options -> ‘Project Preferences’ -> ‘Location Settings’

s WAL B Element Aftributes v TBEEX RS-0~ %A PRQIE& =
[ ) Property Mansger.
o rn s K 5 | @ Cassication anage
= Complex Profiles »
88 A_ 15t STOREY [0, 15 1
r 8 LIRSTOREY (0.1t | e o Certer 30 Fel (30 / A8}
{3 Load Combinations.
B auto intersection
oesign
P & Ada-On Mansger
[ocuner Project Preferences B 7 Working Units. lent Wall
o2 Work Environment ¥ £ Dimensions. ht 3,500
& i B Cakcutation Unic MonfomSrey. -9
< | By Calcutation Rutes..
| [y Zones ent : Slab
A iness 1150
= | —3 Reterence Levels z
A ~ jton from Storey :0
A | () Legacy.
Al "R Stair Rules and Standards.
® ——— B Structural Analytical Model Units
13 Structural Analytical Model Representation.
@ T Structural Load Units.
/.S MEP Preferences.
b Location Settilgs
®) @ Set Project North
- Survey Point
. e PROJECT ZERO
€ E 103° 51'7.57"
B N1°21'3.71"
) 10000 12000
[N
\ 0

2) Fill in details within the Project Location and Survey Point section

~ (1) PROJECT LOCATION
Project Name: -» Fie/nfo/Project o
Ste Full Acdress Address 000000 SNGAPORE

Latitude:

Longaude:

Time Zone (UTC):

Show i Googht Maps. (0]
« @ survey poNT

Symbol Type

BeDH O

wPOSTON
Easting

Northng.

Eevaton
< GEOREFERENCING PARAMETERS FOR IFC

Projected CRS Name Tramverse Mercator

Description

Height Datum (SHO

Map

Easting of Location on Map
= @) PROJECT NORTH

North Angle g [r000

AMtude (Sea Level: 591 absokte (¥ m

¥21 is 3 geodetic coordinate datum based on the WGS4 elipsoid and
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7.2 IFC Export Settings in Archicad
To ensure the best conversion results, we need to have the right import settings. Go to ‘File’ ->

‘Interoperability’ -> ‘IFC’ -> ‘IFC Translators’.

D New Fo-#-c0-8-BrRo-0-|ea
g Open »

X Close Project ~ Ctrl+Shift+W

= = V DREY] 1A taction centen WE
Save Ctri+S s
[B) save as.. Ctrl+Shift+S

(R Export to BIMcloud...

&) Publish BIMx Hyper-model..
r lmeroperaslllxy 0D Merge... » l

» @} IFC Project Manager... Ctri+Alt+1

External Content

Libraries and Objects » D SAF & IFC Translators...
Info »  DXF-DWG * @ IFC Local Preferences..
B Plot Setup... Classifications and Properties » gu Merge to IFC Model...
& Plot.. © Grasshopper Connection.. % Detect IFC Model Changes...
& PageSetup..  CtrlsShiftsp | (5 Import Point Clouds.. {8 Update with IFC Model...
& Print... Ctrl+P Place Mesh from Surveyors Data...
Exit crl+Q Send Model to Google Earth
.
7

Under IFC Translators, go to ‘General Parametric Export’ -> ‘Geometry Conversion’ and ensure
‘Define IFC model position by’ is set to ‘Survey Point and Project Origin’ so that it goes into the right

location in Revit.

= Tvaiaoie presets:
« Optimized for Scia Engineer -
vQ Name of Transiator for & Optimized for Telda Structures
Name General Parametric Expg
) S + = Sraics BRED nanmetry
iiding Desi 4 o~
AECOsm Building Designer import Ferye— New_ Rename.. Delete. B
Alplan Engineenng import Properbes and Classficd . g
DDS-CAD MEP mport |
Exact Gecenetry kinport Conversion of ARCHICAD elements
General import Export only geometries which “Partiipate in Collision Detection™ o
Modeling Applications import - SETTINGS €xport bounding box o
Plancal nova import Export geometry of I Type Products o
IFC Schema:
Revit MEP Import Export gross geometry of elements. “
Revit Structure import Model View Defintion: | Export all model elements” geometry a5
Scia Engineer Import Elements i Sobd Element Operations Extrudedrevohved

Structural analysis Model import Elements weh jnctions Extrudedrevoived without junctions
Tekda Structures import

~  Transiators for Export +

Exact Geometry Export

¥4 Design Transfer View-based Export

Telda Structures Export

Material preservation mode (FC213 only)

Composite structures and Complex Profiles
Spit complex Bullding Elements into parts

IR S

AECOs Building Designer Export Mok Filer: Curtain vl Keep herarchy
Alplan Engineering Export A0 dements | g Keep Nersechy
SiMaYou (40/50) Export 1
Raiing Comvertto single element
Costx Export s i
005-CAD MEP Export S0 el S5

Explode only when necessary 1o preser...

o

€4 Reference View-based Export Property Mappmng: i e, 2 -
WO (50) Bxport Standard #C23 B

Plancal nova Export 1 S

Revit Expont for Reference Model Data Conversion:

Revit MEP Export Element Propertie}

Revit Structure Export |

Scia Engineer Export ' ———

Parametric with exceptions ‘
|
|
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Use the following settings to save the file as IFC.

buildingSMART Singapore
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w
Desktop
=

"
Libraries

2

This PC

o

Network

@ save 3D
Savein | | IFCTEST ‘] @ # e @~
* Name Date modified Type Size
: o Archicad_Coordinate_SPiC.ifc 15/6/2022 10:11 pm Industry Foundatio... 20KB
Quick access = Revit_Coordinate_03_Shared.ifc 15/6/2022 10:09 pm Industry Foundatio... 20K8

Export:

Translator:

File name:

Save astype:

IFC Files (".ic)

Visible elements (on all stories) v Filter...

General Parametric Export v Options...

[Archicad_Coordinate_SPLC1jitc v [ swe ]
=z Cancel

7.3

Importing IFC to Revit for referencing

To import the exported IFC file, click on ‘Link IFC’ and select the appropriate IFC file as shown below.

P
o
Select v Link Import Load from Library
[Properties (P Fa) e @ X
?
@ 30 View o R Link IFC X
IFCTEST > B X B Vews ~
3D View: 30 D v B EditType Name Type
2
- 2 o Archicad_Coordinate_SPLC.ifc Industry Foundatio...
100 o Archicad_Coordinate_SPLC1.ifc Industry Foundatio...
L & Revit Coordinate_03ifc Industry Foundatio..
Ml o Revit_Coordinate_03_Shared.ifc Industry Foundatio...
Pat bility Sho
Visibility/Graphics Overri.
Graphic Display Options
Discipline
Show Hidden Lines F
Default Analysis Display . None
Sun Path
v
e .
roperties hel Apply kL
~
Project Browser - Revit_Coordinate_03.nvt
= 1O Views (all) A
= Floor Plans <
Level 1 File name: lumm_cwm_sﬁcx.k
Level 1D
Level 2 Files of type: Al Supported Files (".ffc, *.fOML, = #cZF)
Site M
= Ceiling Plans Tools QOpen Cancel
Level 1
V4 7
Level 2 / g
= 3D Views Al LR
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Now, you can verify the reference points in Revit.

roperties X {4 3DND Level 1 T level1D X &4 30D

™  FloorPlan -

loor Plan: Level 1 D v B Edit Type
raphics 2 A

isibility/Graphics Overri_ Edit
Graphic Display Options Edit_

Wall Join Display Clean all wall joins

N 37015613 g

e E30000428 2

0. Views (al) ~ EL 5913
Floor Plans
Level 1

Level 1D —
Level 2 b 2F . )
- N’

Site
Ceiling Pians
Level 1
Level 2
30 Views
DD
3DND
Elevations (Building Elevation
Eost

roject Browser - Revit_Coordinate_03 vt X

10000 12000 300
LR

7.4 Adding geo-referencing points in Revit

To add geo-referencing points in Revit, click on ‘Specify Coordinates at a Point’ and fill in the

necessary details in the pop up tab.

& &

r
o

roperties X {7 3DND Levei 1 tevel 10 ——

D View: 3D D £8 Edit Type
aphics * A

Press F1 for more help

Visibility/Graphics Overri. Edit..
(Graphic Display Options Edit.

Default Analysis Display . None
Sun Path

Floor Plans S
Level 1
Level 1D el
Level 2
site

Ceiling Plans
Level 1
Level 2

30 Views
300 7\
30N & TN

Elevations (Building Elevation) (
£ast S 0&
North t9,

South ? % L)

West
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7.5 IFC Export settings in Revit
To export from Revit to IFC, click on ‘File’ -> ‘Export’ -> ‘IFC’ -> ‘Modify Setup’ and ensure that the

Coordinate Base is Shared Coordinates, as shown below.

AT SuuLwic Er rrcuast ydnc ncie 4

|

[

(Y] :B Creates exchange files and sets options.

D New » =g CAD Formats 5
CAD| Creates DWG, DXF, DGN, or SAT files.
‘ . DWF/DWFx
% i % Creates DWF or DWFx files.

4 FBX
E Save ; Saves a 3D view as an FBX file.

Family Types

B s
13 ‘_.‘.C.ifé‘

gbXML
=P Export » Saves the model as a gbXML file.
e
@ e S an IFC file.
l‘f ODBC Database
3 Saves mode! data to an ODBC database.
Q Close
Lacasd .

Options Exit Revit

Modify Setup X

<In-Session Setup> General ' Additional Content | Property Sets | Level of Detail | Advanced
<IFC2x3 Coordination View 2.0 Setup>

<IFC2x3 Coordination View Setup> IFCversion 66 23 Coordinmtion View 20 =
<IFC2x3 GSA Concept Design BIM 2010 Setup> File type IFC v
<IFC2x3 Basic FM Handover View Setup>
<IFC2x2 Coordination View Setup> Phase to export Default phase to export ¥
<IFC2x2 Singapore BCA e-Plan Check Setup>
<IFC2x3 COBie 2.4 Design Deliverable Setup> Space boundaries None ¥
<IFC4 Reference View Setup> =
<IFC4 Design Transfer View Setup> Coordinate Base Blisred Conromaes =
Shared Coo«diwes
[ Split Walls, Columns, Ducts by Level Survey Point
! Include Steel Elements Project Base Point
Internal Origin

Project Address...

bﬁﬁ@fjb‘_‘ ]\OK | Cancel
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Ensure that in the ‘Advanced’ tab, the following option is checked.

Modify Setup %

<In-Session Setup> General | Additional Content | Property Sets | Level of Detail Advanced
<IFC2x3 Coordination View 2.0 Setup> — e
: L] Export parts as building elements
<IFC2x3 Coordination View Setup> = R .
[_] Allow use of mixed "Solid Model” representation
<IFC2x3 GSA Concept Design BIM 2010 Setup>| —
|| Use active view when creating geometry
<IFC2x3 Basic FM Handover View Setup> = 2
. ) |_] Use family and type name for reference
<IFC2x2 Coordination View Setup>
<IFC2x2 Singapore BCA e-Plan Check Setup>
<IFC2x3 COBie 2.4 Design Deliverable Setup>
<IFC4 Reference View Setup>
<IFC4 Design Transfer View Setup>

[C] Use 2D room boundaries for room volume

W/ Include IFCSITE elevation in the site local placement origin
[ Store the IFC GUITY in an element parameter after export
[C] Export bounding box

[] Keep Tessellated Geometry as Triangulation

Use Type name only for IFCType name

Use visible Revit name as the IFCEntity name

DhEH == | ok | | cancel

7.6 Importing IFC to Archicad

In Archicad, go back to ‘IFC Translators’ and ensure that ‘IFC Site Location’ is selected as shown

below.
‘
v Q Name of Translator for import:
Name General Import
~ Translators for Import = D
AECOsim Building Designer Import 1@ Geometry Conversion for IFC Import ? X |non-

Aliplan Engineering Import
DDS-CAD MEP Import Available Presets:
Exact Geometry Import Morphs

objecs

Modeling Applications Import

Plancal nova Import
Revit MEP Import

New... Rename... Delete... a

Revit Structure Import
Scia Engineer Import ~ SETTINGS >
Structural Analysis Model Import . i IFC o ARCHICAD
Tekla Structures import

¥ Translators for Export + Building elements: Construction elements, otherwise Objects | | V|2
AECOskn Bulkding Designer Bxpart Distribution elements: [ MEP elements, otherwise Objects v
Aliplan Engineering Export - E
BIM4You (4D/5D) Export Other elements: Objects vl E V] E=s
Cos» Bxport e site geometry: Morphs vl
DDS-CAD MEP Export - > B
Exact Geometry Export —
7@ General Parametric Export [Dalinehow ta position tha mporfacd £C mcdut-
IFC4 Design Transfer View-based Export Match ARCHICAD Project Origin with: | IFC Site Locatjon (recommended) R 1B
IFC4 Reference View-based Export —
iTWO (SD) Export Origin
plancal nova Export Import unmanmed IFC Profies ac F -
Revit Export for Reference Model @ custom profiles (no new ARCHICAD Attributes are generated)
Revit MEP Export
Revit Structure Export O profile Attributes (new items are added to the ARCHICAD Profile Attribute fist)

Scia Engineer Export
e = » RELATED TRANSLATORS
Tekla Structures Export

New... Delete Set Preview o D Cancel oK

24
Version 1 published 31 January 2025
To feedback on this guide, email enquiry@buildingsmartsingapore.org



buildingSMART,

SINGAPORE

buildingSMART Singapore
BIM Interoperability Guide
Version 1 (31 January 2025)

Click on ‘File’ -> ‘External Content’ -> ‘Place Hotlink’ and select the relevant IFC file, as shown below.

D New B SO0 AR - O~ -8E
g Open » R Type: Font Size and Rotation:

; i plao0 |
[X Close Project ~ Ctrisshiftew  [— = M{.;I
X Lea - ect | e [000°

j =R

Save ciss o0 * | fitacion centen
[B) save as... Ctrl+Shift+S

[f?\ Export to BIMcloud...

&) Publish BIMx Hyper-model..

bkt A ] | __ o
[ e conen Gl Pty

Libraries and Objects > eak K

Info »

[El Save Selection as Module...
@& Hotlink Module Manager...

Plot Setup...

i Piot..

% Page Setup... Ctrl+Shift+P B Place External Drawing... —]
@ Print... Ctrl+P @ Place External Drawing from BiMcloud ...
Exit Ctrl+Q EE Drawing Manager
A [ Attach Xref...
/ ﬂ Xref Manager...
FAnY l
= O-8-BEXES-O-RATMFHAFEQGICER|IA-AL
Font Size and Rotation: Q Text Alignment:
Mo :
_ S Y Defaut
/& New Hotlink Module X
Lookin: IFCTEST vl @2 =B8R
* Name » Date modified Type Size
== Archicad_Coordinate_SPLC.ifc 15/6/2022 10:11 pm Industry Foundatio... 20K8
Quick Mgss &, Archicad_Coordinate_SPLC1.ifc 15/6/2022 1123 pm Industry Foundatio... 20K8
- o Revit_Coordinate_03.ifc 15/6/2022 11:27 pm Industry Foundatio.. 20K8
== Revit_Coordinate_03_Shared.ifc 15/6/2022 10:09 pm Industry Foundatio... 20KB
Desktop
=
™
Libraries
This PC
Network
Translator: General import (from ARCHICAD 25 Template.tpl) ~ Options...
File name: Revit_Coordinate_03.ifc v Select B
Files oftype: IFC Files (".dc: * o * ficzip) v Cancel
NT 21T 371" I
* 10.00 Cancel Place Hotlink... 300 |
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Ensure that external location is selected as shown below.

/@8 Library Parts Location ? X
® Importing: Revit_Coordinate_03.ifc - All Stories - ARCHICAD 25 Template, General
Import
Save Library Parts generated during import to:
(O embedded Library

@ external location

\ Users\CChidambaram\Documents| Browse...

Create Library Container File (cf)

A When hotlinking IFC, the folder generated at the selected location must be manually
linked to the host project as a Linked Library.

[Joont show this dialog again

| o]

Check through the Revit file and you should find that the coordinates match with the original

Archicad file.

O VA B X H R cH-BEXES-O-RATMFEAIPFREQIEE | A-ATE

vain fros [ Poor ian e Secton: Unked Stones Bettom anc Top o Tl
"::“‘,“;53 ] [~ ®awu—cicmdd » T ouside race + =3 B> BBocenver > By foorpenamdsecion.  » .Z :":;:n : gl z”:c" -
88 (4 15t sTOREY (0. 12t STOREY) 1 1action centery J)0) 30 amotation (30 / A1} s b~
R 2 OBERY
3 v O -> Fae/mbojproject info
besion 30
Fewpon o | 30 (simplified)
K55 v 5 M WORKING Views
10. ROOF STOREY
™ 5. 10th sTOREY
") . oth STOREY
) 7. 8th sTOREY
™3 6 7th sTOREY
(™5 . éth sTOREY
" 4. 5th STOREY
¥ ") 3. 4th STOREY
@ ™5 2. 3ra sTorey
1. 2nd STOREY
4 ™5 0. 15t sToREY
D SUBMISSION
£ menoer
v B steps
[ anghe Setting
L1 5. 15t STOREY

") w_ 15t STOREY

B ®E o X
S
For a full detailed walk-though of this, please refer to the video in this link.
26

Version 1 published 31 January 2025
To feedback on this guide, email enquiry@buildingsmartsingapore.org


https://graphisoft.sharefile.com/share/view/s743946e891c34b9db46bf5c41f1ec42d

	1. Objective
	2. Prerequisites & References
	3. Preparing the Archicad Model
	3.1 Classifying Elements
	3.2 Defining the Properties
	3.3 Defining IFC Translator Setting
	3.4 Quality Check within Archicad

	4. Exporting IFC
	4.1 IFC Export Settings from Archicad

	5. Model Quality Check
	6. IFC Import to Revit
	6.1 Import Configuration
	6.2 IFC Mapping to Revit

	7. Geo-referencing in Archicad and Revit
	7.1 Adding geo-referencing values to Archicad
	7.2 IFC Export Settings in Archicad
	7.3 Importing IFC to Revit for referencing
	7.4 Adding geo-referencing points in Revit
	7.5 IFC Export settings in Revit
	7.6 Importing IFC to Archicad


